{"action":"Upgrade libssh2 to 1.8.1-r0 or later.","affected":[{"fixed":"1.8.1-r0","introduced":"0.3"}],"component":"libssh2","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.10","exploited":false,"fixed_versions":["1.8.1-r0"],"id":"tcs_01M5NBQPPB5TAMCJPV3DAF9D4W","modified_at":"2026-09-21T06:17:52.520563286Z","published_at":"2019-03-25T19:29:01.883Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2019-3860","https://security.alpinelinux.org/vuln/CVE-2019-3860"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2019-3860","url":"https://osv.dev/vulnerability/ALPINE-CVE-2019-3860"}],"summary":"An out of bounds read flaw was discovered in libssh2 before 1.8.1 in the way SFTP packets with empty payloads are parsed. A remote attacker who compromises a SSH server may be able to cause a Denial o"}