{"action":"Upgrade ghostscript to 9.19~dfsg-3.1 or later.","affected":[{"fixed":"9.19~dfsg-3.1","introduced":"0"}],"component":"ghostscript","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["9.19~dfsg-3.1"],"id":"tcs_01M5NBRSZTFHXBA67YCY8EACAN","modified_at":"2026-09-22T07:02:26.456633294Z","published_at":"2017-05-23T04:29:01.570Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2016-7978","https://security-tracker.debian.org/tracker/CVE-2016-7978"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2016-7978","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2016-7978"}],"summary":"Use-after-free vulnerability in Ghostscript 9.20 might allow remote attackers to execute arbitrary code via vectors related to a reference leak in .setdevice."}