{"action":"Upgrade ghostscript to 9.19~dfsg-3.1 or later.","affected":[{"fixed":"9.19~dfsg-3.1","introduced":"0"}],"component":"ghostscript","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["9.19~dfsg-3.1"],"id":"tcs_01M5NBRT7F7DNZ55CZT80HSJ3X","modified_at":"2026-09-22T07:02:26.798710180Z","published_at":"2017-05-23T04:29:01.617Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2016-7979","https://security-tracker.debian.org/tracker/CVE-2016-7979"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2016-7979","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2016-7979"}],"summary":"Ghostscript before 9.21 might allow remote attackers to bypass the SAFER mode protection mechanism and consequently execute arbitrary code by leveraging type confusion in .initialize_dsc_parser."}