{"action":"Upgrade ansible to 2.2.0.0-3 or later.","affected":[{"fixed":"2.2.0.0-3","introduced":"0"}],"component":"ansible","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.2.0.0-3"],"id":"tcs_01M5NBTRQRADDY5ZYMPH1V1TFD","modified_at":"2026-09-22T07:02:42.161832848Z","published_at":"2018-04-24T16:29:00.220Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2016-9587","https://security-tracker.debian.org/tracker/CVE-2016-9587"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2016-9587#Debian:13/ansible","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2016-9587"}],"summary":"Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems. An attacker with control over a client system being managed b"}