{"action":"Upgrade puppet-module-swift to 9.4.4-1 or later.","affected":[{"fixed":"9.4.4-1","introduced":"0"}],"component":"puppet-module-swift","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["9.4.4-1"],"id":"tcs_01M5NBTS6KC652Q0STGCAK3514","modified_at":"2026-09-22T07:00:10.943284476Z","published_at":"2018-04-26T17:29:00.230Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2016-9590","https://security-tracker.debian.org/tracker/CVE-2016-9590"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2016-9590#Debian:13/puppet-module-swift","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2016-9590"}],"summary":"puppet-swift before versions 8.2.1, 9.4.4 is vulnerable to an information-disclosure in Red Hat OpenStack Platform director's installation of Object Storage (swift). During installation, the Puppet sc"}