{"action":"Upgrade webkit2gtk to 2.16.3-2 or later.","affected":[{"fixed":"2.16.3-2","introduced":"0"}],"component":"webkit2gtk","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.16.3-2"],"id":"tcs_01M5NBWFEG5EKSNMAC3XCTA9NS","modified_at":"2026-09-01T20:03:40.337114314Z","published_at":"2017-11-01T21:29:00.280Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-1000121","https://security-tracker.debian.org/tracker/CVE-2017-1000121"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-1000121#Debian:14/webkit2gtk","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-1000121"}],"summary":"The UNIX IPC layer in WebKit, including WebKitGTK+ prior to 2.16.3, does not properly validate message size metadata, allowing a compromised secondary process to trigger an integer overflow and subseq"}