{"action":"Upgrade python2.7 to 2.7.13-4 or later.","affected":[{"fixed":"2.7.13-4","introduced":"0"}],"component":"python2.7","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:11","exploited":false,"fixed_versions":["2.7.13-4"],"id":"tcs_01M5NBWFR8JMN86807GWGEV8V4","modified_at":"2026-08-04T05:48:01.154252038Z","published_at":"2017-11-17T05:29:00.280Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-1000158","https://security-tracker.debian.org/tracker/CVE-2017-1000158"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-1000158","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-1000158"}],"summary":"CPython (aka Python) up to 2.7.13 is vulnerable to an integer overflow in the PyString_DecodeEscape function in stringobject.c, resulting in heap-based buffer overflow (and possible arbitrary code exe"}