{"action":"Upgrade node-ejs to 2.5.7-1 or later.","affected":[{"fixed":"2.5.7-1","introduced":"0"}],"component":"node-ejs","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.5.7-1"],"id":"tcs_01M5NBWG6WSN9DC9N3GS183775","modified_at":"2026-09-01T20:03:40.935554053Z","published_at":"2017-11-17T03:29:00.267Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-1000188","https://security-tracker.debian.org/tracker/CVE-2017-1000188"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-1000188","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-1000188"}],"summary":"nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the ejs.renderFile() resulting in code injection"}