{"action":"Upgrade node-ejs to 2.5.7-1 or later.","affected":[{"fixed":"2.5.7-1","introduced":"0"}],"component":"node-ejs","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.5.7-1"],"id":"tcs_01M5NBWGKEA61710EWR7Z9J6FS","modified_at":"2026-09-01T20:03:40.931159912Z","published_at":"2017-11-17T03:29:00.300Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-1000189","https://security-tracker.debian.org/tracker/CVE-2017-1000189"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-1000189#Debian:14/node-ejs","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-1000189"}],"summary":"nodejs ejs version older than 2.5.5 is vulnerable to a denial-of-service due to weak input validation in the ejs.renderFile()"}