{"action":"Upgrade python-pysaml2 to 4.5.0-2 or later.","affected":[{"fixed":"4.5.0-2","introduced":"0"}],"component":"python-pysaml2","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["4.5.0-2"],"id":"tcs_01M5NBWXCRFYNWABSBYT3AJQNP","modified_at":"2026-09-01T20:03:40.987127981Z","published_at":"2018-01-02T23:29:00.337Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-1000433","https://security-tracker.debian.org/tracker/CVE-2017-1000433"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-1000433#Debian:14/python-pysaml2","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-1000433"}],"summary":"pysaml2 version 4.4.0 and older accept any password when run with python optimizations enabled. This allows attackers to log in as any user without knowing their password."}