{"action":"Upgrade smarty3 to 3.1.31+20161214.1.c7d42e4+selfpack1-3 or later.","affected":[{"fixed":"3.1.31+20161214.1.c7d42e4+selfpack1-3","introduced":"0"}],"component":"smarty3","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["3.1.31+20161214.1.c7d42e4+selfpack1-3"],"id":"tcs_01M5NBWZ2J3ZKPJ5FHA3X3RKKW","modified_at":"2026-09-01T20:03:40.890492288Z","published_at":"2018-01-03T18:29:00.370Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-1000480","https://security-tracker.debian.org/tracker/CVE-2017-1000480"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-1000480","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-1000480"}],"summary":"Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name."}