{"action":"Upgrade ruby-saml to 1.7.2-1 or later.","affected":[{"fixed":"1.7.2-1","introduced":"0"}],"component":"ruby-saml","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.7.2-1"],"id":"tcs_01M5NBY20HKBSKBCY8MMY5XBAC","modified_at":"2026-09-01T20:03:40.989001733Z","published_at":"2019-04-17T14:29:00.323Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-11428","https://security-tracker.debian.org/tracker/CVE-2017-11428"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-11428","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-11428"}],"summary":"OneLogin Ruby-SAML 1.6.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without i"}