{"action":"Upgrade undertow to 2.0.23-1 or later.","affected":[{"fixed":"2.0.23-1","introduced":"0"}],"component":"undertow","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.0.23-1"],"id":"tcs_01M5NBZ8B67HH832EP2QPB0X49","modified_at":"2026-09-01T20:03:41.857720719Z","published_at":"2018-07-27T15:29:00.237Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-12165","https://security-tracker.debian.org/tracker/CVE-2017-12165"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-12165","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-12165"}],"summary":"It was discovered that Undertow before 1.4.17, 1.3.31 and 2.0.0 processes http request headers with unusual whitespaces which can cause possible http request smuggling."}