{"action":"Upgrade xorg-server to 2:1.19.5-1 or later.","affected":[{"fixed":"2:1.19.5-1","introduced":"0"}],"component":"xorg-server","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2:1.19.5-1"],"id":"tcs_01M5NBZ9EPCZ296GT8C0PX8PT3","modified_at":"2026-09-01T20:03:42.031550898Z","published_at":"2018-01-24T15:29:00.247Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-12176","https://security-tracker.debian.org/tracker/CVE-2017-12176"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-12176#Debian:14/xorg-server","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-12176"}],"summary":"xorg-x11-server before 1.19.5 was missing extra length validation in ProcEstablishConnection function allowing malicious X client to cause X server to crash or possibly execute arbitrary code."}