{"action":"Upgrade shadow to 1:4.5-1 or later.","affected":[{"fixed":"1:4.5-1","introduced":"0"}],"component":"shadow","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1:4.5-1"],"id":"tcs_01M5NBZGAK7R1TMN2NZC8PJB0C","modified_at":"2026-09-01T20:03:42.082311206Z","published_at":"2017-08-04T09:29:00.187Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-12424","https://security-tracker.debian.org/tracker/CVE-2017-12424"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-12424","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-12424"}],"summary":"In shadow before 4.5, the newusers tool could be made to manipulate internal data structures in ways unintended by the authors. Malformed input may lead to crashes (with a buffer overflow or other mem"}