{"action":"Upgrade binutils to 2.29-8 or later.","affected":[{"fixed":"2.29-8","introduced":"0"}],"component":"binutils","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.29-8"],"id":"tcs_01M5NBZQFN0ZRS04GK5R1J900T","modified_at":"2026-09-01T20:03:42.142998421Z","published_at":"2017-08-04T15:29:00.700Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-12458","https://security-tracker.debian.org/tracker/CVE-2017-12458"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-12458","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-12458"}],"summary":"The nlm_swap_auxiliary_headers_in function in bfd/nlmcode.h in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.29 and earlier, allows remote attackers to cause"}