{"action":"Upgrade putty to 0.71-r0 or later.","affected":[{"fixed":"0.71-r0","introduced":"0"}],"component":"putty","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.8","exploited":false,"fixed_versions":["0.71-r0"],"id":"tcs_01M5NC04ZC4JP8V3DZXZMC4YN4","modified_at":"2026-09-21T06:17:52.560772697Z","published_at":"2019-03-21T16:01:17.890Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2019-9898","https://security.alpinelinux.org/vuln/CVE-2019-9898"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2019-9898#Alpine:v3.8/putty","url":"https://osv.dev/vulnerability/ALPINE-CVE-2019-9898"}],"summary":"Potential recycling of random numbers used in cryptography exists within PuTTY before 0.71."}