{"action":"Upgrade imagemagick to 8:6.9.9.34+dfsg-3 or later.","affected":[{"fixed":"8:6.9.9.34+dfsg-3","introduced":"0"}],"component":"imagemagick","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["8:6.9.9.34+dfsg-3"],"id":"tcs_01M5NC0D3GAZC46HTPZZEK3CYN","modified_at":"2026-09-01T20:03:42.611375520Z","published_at":"2017-08-28T19:29:00.790Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-12877","https://security-tracker.debian.org/tracker/CVE-2017-12877"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-12877","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-12877"}],"summary":"Use-after-free vulnerability in the DestroyImage function in image.c in ImageMagick before 7.0.6-6 allows remote attackers to cause a denial of service via a crafted file."}