{"action":"Upgrade libidn to 1.33-2 or later.","affected":[{"fixed":"1.33-2","introduced":"0"}],"component":"libidn","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.33-2"],"id":"tcs_01M5NC3561FSTD8N5MHBY3WSHB","modified_at":"2026-09-01T20:03:43.692482935Z","published_at":"2017-08-31T16:29:00.270Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-14062","https://security-tracker.debian.org/tracker/CVE-2017-14062"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-14062#Debian:14/libidn","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-14062"}],"summary":"Integer overflow in the decode_digit function in puny_decode.c in Libidn2 before 2.0.4 allows remote attackers to cause a denial of service or possibly have unspecified other impact."}