{"action":"Upgrade putty to 0.74-r0 or later.","affected":[{"fixed":"0.74-r0","introduced":"0.68"}],"component":"putty","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.15","exploited":false,"fixed_versions":["0.74-r0"],"id":"tcs_01M5NC5CQGDFXG7A7J9SV710DF","modified_at":"2026-10-26T11:17:55.115183553Z","published_at":"2020-06-29T18:15:11.767Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2020-14002","https://security.alpinelinux.org/vuln/CVE-2020-14002"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2020-14002#Alpine:v3.15/putty","url":"https://osv.dev/vulnerability/ALPINE-CVE-2020-14002"}],"summary":"PuTTY 0.68 through 0.73 has an Observable Discrepancy leading to an information leak in the algorithm negotiation. This allows man-in-the-middle attackers to target initial connection attempts (where"}