{"action":"Upgrade pdns-recursor to 4.0.7-1 or later.","affected":[{"fixed":"4.0.7-1","introduced":"0"}],"component":"pdns-recursor","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["4.0.7-1"],"id":"tcs_01M5NC5FGT0F7VE0DVNP6SD8N4","modified_at":"2026-09-01T20:03:44.340744012Z","published_at":"2018-01-23T15:29:00.417Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-15094","https://security-tracker.debian.org/tracker/CVE-2017-15094"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-15094#Debian:13/pdns-recursor","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-15094"}],"summary":"An issue has been found in the DNSSEC parsing code of PowerDNS Recursor from 4.0.0 up to and including 4.0.6 leading to a memory leak when parsing specially crafted DNSSEC ECDSA keys. These keys are o"}