{"action":"Upgrade dnsmasq to 2.79-1 or later.","affected":[{"fixed":"2.79-1","introduced":"0"}],"component":"dnsmasq","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.79-1"],"id":"tcs_01M5NC5M4APHM2FXJNHJDG36MG","modified_at":"2026-09-01T20:03:44.319807496Z","published_at":"2018-01-23T16:29:00.477Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-15107","https://security-tracker.debian.org/tracker/CVE-2017-15107"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-15107","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-15107"}],"summary":"A vulnerability was found in the implementation of DNSSEC in Dnsmasq up to and including 2.78. Wildcard synthesized NSEC records could be improperly interpreted to prove the non-existence of hostnames"}