{"action":"Upgrade libcatalyst-plugin-static-simple-perl to 0.34-1 or later.","affected":[{"fixed":"0.34-1","introduced":"0"}],"component":"libcatalyst-plugin-static-simple-perl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.34-1"],"id":"tcs_01M5NC7FSBQF4GPJJTPH86TKJ6","modified_at":"2026-09-01T20:03:45.565324663Z","published_at":"2017-11-01T01:29:01.010Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-16248","https://security-tracker.debian.org/tracker/CVE-2017-16248"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-16248","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-16248"}],"summary":"The Catalyst-Plugin-Static-Simple module before 0.34 for Perl allows remote attackers to read arbitrary files if there is a '.' character anywhere in the pathname, which differs from the intended poli"}