{"action":"Upgrade xrdp to 0.9.4-3 or later.","affected":[{"fixed":"0.9.4-3","introduced":"0"}],"component":"xrdp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.9.4-3"],"id":"tcs_01M5NC8PEBYHAJ2P08RFXNA1SY","modified_at":"2026-09-01T20:03:45.226649314Z","published_at":"2017-11-23T06:29:00.210Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-16927","https://security-tracker.debian.org/tracker/CVE-2017-16927"],"severity":{"label":"high","score":8.4},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-16927","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-16927"}],"summary":"The scp_v0s_accept function in sesman/libscp/libscp_v0.c in the session manager in xrdp through 0.9.4 uses an untrusted integer as a write length, which allows local users to cause a denial of service"}