{"action":"Upgrade mercurial to 4.4.1-1 or later.","affected":[{"fixed":"4.4.1-1","introduced":"0"}],"component":"mercurial","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["4.4.1-1"],"id":"tcs_01M5NC982DVZTRQ3HQ4AWJCRZP","modified_at":"2026-09-01T20:03:45.665691262Z","published_at":"2017-12-07T18:29:00.203Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-17458","https://security-tracker.debian.org/tracker/CVE-2017-17458"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-17458","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-17458"}],"summary":"In Mercurial before 4.4.1, it is possible that a specially malformed repository can cause Git subrepositories to run arbitrary code in the form of a .git/hooks/post-update script checked into the repo"}