{"action":"Upgrade vlc to 3.0.0~rc2-1 or later.","affected":[{"fixed":"3.0.0~rc2-1","introduced":"0"}],"component":"vlc","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["3.0.0~rc2-1"],"id":"tcs_01M5NC9S21EFEATXHTZAFWR8EY","modified_at":"2026-09-01T20:03:45.737687837Z","published_at":"2017-12-15T09:29:00.250Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-17670","https://security-tracker.debian.org/tracker/CVE-2017-17670"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-17670","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-17670"}],"summary":"In VideoLAN VLC media player through 2.2.8, there is a type conversion vulnerability in modules/demux/mp4/libmp4.c in the MP4 demux module leading to a invalid free, because the type of a box may be c"}