{"action":"Upgrade jruby to 9.3.9.0+ds-1 or later.","affected":[{"fixed":"9.3.9.0+ds-1","introduced":"0"}],"component":"jruby","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["9.3.9.0+ds-1"],"id":"tcs_01M5NC9WPC169Q7TRP7PBAT2CW","modified_at":"2026-09-01T20:03:45.812035852Z","published_at":"2018-04-03T22:29:00.383Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-17742","https://security-tracker.debian.org/tracker/CVE-2017-17742"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-17742#Debian:14/jruby","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-17742"}],"summary":"Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1 allows an HTTP Response Splitting attack. An attacker can inject a crafted key and value into an HTTP"}