{"action":"Upgrade mbedtls to 2.7.0-2 or later.","affected":[{"fixed":"2.7.0-2","introduced":"0"}],"component":"mbedtls","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.7.0-2"],"id":"tcs_01M5NCAWBGA0H7GGFZHFSER8M0","modified_at":"2026-09-01T20:03:46.938695528Z","published_at":"2018-02-14T17:29:00.237Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-18187","https://security-tracker.debian.org/tracker/CVE-2017-18187"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-18187#Debian:14/mbedtls","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-18187"}],"summary":"In ARM mbed TLS before 2.7.0, there is a bounds-check bypass through an integer overflow in PSK identity parsing in the ssl_parse_client_psk_identity() function in library/ssl_srv.c."}