{"action":"Upgrade postgis to 2.3.3+dfsg-1 or later.","affected":[{"fixed":"2.3.3+dfsg-1","introduced":"0"}],"component":"postgis","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.3.3+dfsg-1"],"id":"tcs_01M5NCBHWFSA7SGDA525C3XPQG","modified_at":"2026-09-01T20:03:47.542965557Z","published_at":"2019-01-25T05:29:00.700Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-18359","https://security-tracker.debian.org/tracker/CVE-2017-18359"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-18359","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-18359"}],"summary":"PostGIS 2.x before 2.3.3, as used with PostgreSQL, allows remote attackers to cause a denial of service via crafted ST_AsX3D function input, as demonstrated by an abnormal server termination for \"SELE"}