{"action":"Upgrade libvncserver to 0.9.12+dfsg-3 or later.","affected":[{"fixed":"0.9.12+dfsg-3","introduced":"0"}],"component":"libvncserver","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.9.12+dfsg-3"],"id":"tcs_01M5NCBQP0TESRGVMSQX8JQP43","modified_at":"2026-09-01T20:02:53.328075145Z","published_at":"2020-06-30T11:15:10.380Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-18922","https://security-tracker.debian.org/tracker/CVE-2017-18922"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-18922","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-18922"}],"summary":"It was discovered that websockets.c in LibVNCServer prior to 0.9.12 did not properly decode certain WebSocket frames. A malicious attacker could exploit this by sending specially crafted WebSocket fra"}