{"action":"Upgrade clojure to 1.9.0-1 or later.","affected":[{"fixed":"1.9.0-1","introduced":"0"}],"component":"clojure","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.9.0-1"],"id":"tcs_01M5NCBTV2P38GVSMKJY41M237","modified_at":"2026-09-01T20:03:47.344847427Z","published_at":"2024-01-22T06:15:07.563Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-20189","https://security-tracker.debian.org/tracker/CVE-2017-20189"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-20189","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-20189"}],"summary":"In Clojure before 1.9.0, classes can be used to construct a serialized object that executes arbitrary code upon deserialization. This is relevant if a server deserializes untrusted objects."}