{"action":"Upgrade libyaml-perl to 1.30-1 or later.","affected":[{"fixed":"1.30-1","introduced":"0"}],"component":"libyaml-perl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.30-1"],"id":"tcs_01M5NCBW0JJR5B42SRGWF66ZJS","modified_at":"2026-10-07T10:00:04.144896584Z","published_at":"2026-10-05T07:16:29.017Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-20285","https://security-tracker.debian.org/tracker/CVE-2017-20285"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-20285","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-20285"}],"summary":"YAML versions before 1.30 for Perl allow a loaded document to trigger the DESTROY method of arbitrary classes. A perl/hash:Class tag blesses a hash into the class it names. The document supplies the o"}