{"action":"Upgrade puppet to 4.8.2-5 or later.","affected":[{"fixed":"4.8.2-5","introduced":"0"}],"component":"puppet","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:11","exploited":false,"fixed_versions":["4.8.2-5"],"id":"tcs_01M5NCBWSGNN97P02QY70G2XS6","modified_at":"2026-08-04T05:48:04.197779748Z","published_at":"2017-07-05T15:29:00.207Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-2295","https://security-tracker.debian.org/tracker/CVE-2017-2295"],"severity":{"label":"high","score":8.2},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-2295","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-2295"}],"summary":"Versions of Puppet prior to 4.10.1 will deserialize data off the wire (from the agent to the server, in this case) with a attacker-specified format. This could be used to force YAML deserialization in"}