{"action":"Upgrade python-oslo.middleware to 3.19.0-3 or later.","affected":[{"fixed":"3.19.0-3","introduced":"0"}],"component":"python-oslo.middleware","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.19.0-3"],"id":"tcs_01M5NCCRBYY18WYWX83KV2G6W2","modified_at":"2026-09-01T20:03:48.266174034Z","published_at":"2018-05-08T17:29:00.560Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-2592","https://security-tracker.debian.org/tracker/CVE-2017-2592"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-2592#Debian:14/python-oslo.middleware","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-2592"}],"summary":"python-oslo-middleware before versions 3.8.1, 3.19.1, 3.23.1 is vulnerable to an information disclosure. Software using the CatchError class could include sensitive values in a traceback's error messa"}