{"action":"Upgrade pcs to 0.9.155+dfsg-2 or later.","affected":[{"fixed":"0.9.155+dfsg-2","introduced":"0"}],"component":"pcs","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.9.155+dfsg-2"],"id":"tcs_01M5NCD0SQNFYR74DSFF1Y0TZA","modified_at":"2026-09-01T20:03:05.299961563Z","published_at":"2018-03-12T15:29:00.553Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-2661","https://security-tracker.debian.org/tracker/CVE-2017-2661"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-2661#Debian:14/pcs","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-2661"}],"summary":"ClusterLabs pcs before version 0.9.157 is vulnerable to a cross-site scripting vulnerability due to improper validation of Node name field when creating new cluster or adding existing cluster."}