{"action":"Upgrade squid to 5.0.5-r0 or later.","affected":[{"fixed":"5.0.5-r0","introduced":"2.0"}],"component":"squid","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.16","exploited":false,"fixed_versions":["5.0.5-r0"],"id":"tcs_01M5NCE407756R5VH9HEPSFPSR","modified_at":"2026-10-26T11:17:55.151601989Z","published_at":"2021-03-19T05:15:12.480Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2020-25097","https://security.alpinelinux.org/vuln/CVE-2020-25097"],"severity":{"label":"high","score":8.6},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2020-25097#Alpine:v3.16/squid","url":"https://osv.dev/vulnerability/ALPINE-CVE-2020-25097"}],"summary":"An issue was discovered in Squid through 4.13 and 5.x through 5.0.4. Due to improper input validation, it allows a trusted client to perform HTTP Request Smuggling and access services otherwise forbid"}