{"action":"Upgrade putty to 0.67-3 or later.","affected":[{"fixed":"0.67-3","introduced":"0"}],"component":"putty","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.67-3"],"id":"tcs_01M5NCHNX1AMSZR99T809W0668","modified_at":"2026-09-01T20:03:49.299666977Z","published_at":"2017-03-27T17:59:00.850Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-6542","https://security-tracker.debian.org/tracker/CVE-2017-6542"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-6542#Debian:13/putty","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-6542"}],"summary":"The ssh_agent_channel_data function in PuTTY before 0.68 allows remote attackers to have unspecified impact via a large length value in an agent protocol message and leveraging the ability to connect"}