{"action":"Upgrade linux to 4.9.25-1 or later.","affected":[{"fixed":"4.9.25-1","introduced":"0"}],"component":"linux","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["4.9.25-1"],"id":"tcs_01M5NCKPDVAA6HKZKCS5ZAP6FR","modified_at":"2026-09-01T20:03:50.088651077Z","published_at":"2017-04-25T14:59:00.213Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-7477","https://security-tracker.debian.org/tracker/CVE-2017-7477"],"severity":{"label":"high","score":7},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-7477","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-7477"}],"summary":"Heap-based buffer overflow in drivers/net/macsec.c in the MACsec module in the Linux kernel through 4.10.12 allows attackers to cause a denial of service or possibly have unspecified other impact by l"}