{"action":"Upgrade mosquitto to 1.5.4-1 or later.","affected":[{"fixed":"1.5.4-1","introduced":"0"}],"component":"mosquitto","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1.5.4-1"],"id":"tcs_01M5NCMGKY591JMNTTSDSM7KWH","modified_at":"2026-09-01T20:03:50.332477991Z","published_at":"2018-06-05T20:29:00.340Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-7654","https://security-tracker.debian.org/tracker/CVE-2017-7654"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-7654#Debian:13/mosquitto","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-7654"}],"summary":"In Eclipse Mosquitto 1.4.15 and earlier, a Memory Leak vulnerability was found within the Mosquitto Broker. Unauthenticated clients can send crafted CONNECT packets which could cause a denial of servi"}