{"action":"Upgrade vlc to 2.2.5-1 or later.","affected":[{"fixed":"2.2.5-1","introduced":"0"}],"component":"vlc","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.2.5-1"],"id":"tcs_01M5NCP81889P41E8GZX2ETPW6","modified_at":"2026-09-01T20:03:50.880746307Z","published_at":"2017-05-23T21:29:00.227Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-8311","https://security-tracker.debian.org/tracker/CVE-2017-8311"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-8311#Debian:14/vlc","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-8311"}],"summary":"Potential heap based buffer overflow in ParseJSS in VideoLAN VLC before 2.2.5 due to skipping NULL terminator in an input string allows attackers to execute arbitrary code via a crafted subtitles file"}