{"action":"Upgrade strongswan to 5.5.1-4 or later.","affected":[{"fixed":"5.5.1-4","introduced":"0"}],"component":"strongswan","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["5.5.1-4"],"id":"tcs_01M5NCQAVC3EJSQQ85HVXKHFBP","modified_at":"2026-09-01T20:03:51.306496041Z","published_at":"2017-06-08T16:29:00.497Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-9022","https://security-tracker.debian.org/tracker/CVE-2017-9022"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-9022#Debian:14/strongswan","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-9022"}],"summary":"The gmp plugin in strongSwan before 5.5.3 does not properly validate RSA public keys before calling mpz_powm_sec, which allows remote peers to cause a denial of service (floating point exception and p"}