{"action":"Upgrade strongswan to 5.5.1-4 or later.","affected":[{"fixed":"5.5.1-4","introduced":"0"}],"component":"strongswan","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["5.5.1-4"],"id":"tcs_01M5NCQB1WT80QXCS10Y0X737R","modified_at":"2026-09-01T20:03:51.261305357Z","published_at":"2017-06-08T16:29:00.543Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-9023","https://security-tracker.debian.org/tracker/CVE-2017-9023"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-9023#Debian:13/strongswan","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-9023"}],"summary":"The ASN.1 parser in strongSwan before 5.5.3 improperly handles CHOICE types when the x509 plugin is enabled, which allows remote attackers to cause a denial of service (infinite loop) via a crafted ce"}