{"action":"Upgrade libxml2 to 2.9.4+dfsg1-3.1 or later.","affected":[{"fixed":"2.9.4+dfsg1-3.1","introduced":"0"}],"component":"libxml2","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.9.4+dfsg1-3.1"],"id":"tcs_01M5NCQEZ4PBS9AMCKT2V3GX6K","modified_at":"2026-10-15T07:47:22.857782715Z","published_at":"2017-05-18T06:29:00.467Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-9049","https://security-tracker.debian.org/tracker/CVE-2017-9049"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-9049#Debian:14/libxml2","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-9049"}],"summary":"libxml2 20904-GITv2.9.4-16-g0741801 is vulnerable to a heap-based buffer over-read in the xmlDictComputeFastKey function in dict.c. This vulnerability causes programs that use libxml2, such as PHP, to"}