{"action":"Upgrade chicken to 4.12.0-0.2 or later.","affected":[{"fixed":"4.12.0-0.2","introduced":"0"}],"component":"chicken","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["4.12.0-0.2"],"id":"tcs_01M5NCRM50BSWP5WZESBQPR9B8","modified_at":"2026-09-01T20:03:51.673219253Z","published_at":"2017-06-01T05:29:00.233Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-9334","https://security-tracker.debian.org/tracker/CVE-2017-9334"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-9334#Debian:13/chicken","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-9334"}],"summary":"An incorrect \"pair?\" check in the Scheme \"length\" procedure results in an unsafe pointer dereference in all CHICKEN Scheme versions prior to 4.13, which allows an attacker to cause a denial of service"}