{"action":"Upgrade grpc to 1.3.2-0.1 or later.","affected":[{"fixed":"1.3.2-0.1","introduced":"0"}],"component":"grpc","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.3.2-0.1"],"id":"tcs_01M5NCRZ2TW2XJMKK9GGWYX6QR","modified_at":"2026-09-01T20:03:51.754982266Z","published_at":"2017-06-05T03:29:00.197Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2017-9431","https://security-tracker.debian.org/tracker/CVE-2017-9431"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2017-9431#Debian:14/grpc","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2017-9431"}],"summary":"Google gRPC before 2017-04-05 has an out-of-bounds write caused by a heap-based buffer overflow related to core/lib/iomgr/error.c."}