{"action":"Upgrade zsh to 5.6-1 or later.","affected":[{"fixed":"5.6-1","introduced":"0"}],"component":"zsh","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["5.6-1"],"id":"tcs_01M5NCT9ARBH19V46VV80MFC8T","modified_at":"2026-10-23T18:02:55.800373942Z","published_at":"2018-09-05T08:29:00.230Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-0502","https://security-tracker.debian.org/tracker/CVE-2018-0502"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-0502#Debian:13/zsh","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-0502"}],"summary":"An issue was discovered in zsh before 5.6. The beginning of a #! script file was mishandled, potentially leading to an execve call to a program named on the second line."}