{"action":"Upgrade librelp to 1.2.15-1 or later.","affected":[{"fixed":"1.2.15-1","introduced":"0"}],"component":"librelp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1.2.15-1"],"id":"tcs_01M5NCTXZCHHJM4RXSZCAD49VG","modified_at":"2026-10-23T18:03:17.981463117Z","published_at":"2018-03-23T21:29:00.647Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-1000140","https://security-tracker.debian.org/tracker/CVE-2018-1000140"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-1000140#Debian:13/librelp","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-1000140"}],"summary":"rsyslog librelp version 1.2.14 and earlier contains a Buffer Overflow vulnerability in the checking of x509 certificates from a peer that can result in Remote code execution. This attack appear to be"}