{"action":"Upgrade bouncycastle to 1.59-2 or later.","affected":[{"fixed":"1.59-2","introduced":"0"}],"component":"bouncycastle","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.59-2"],"id":"tcs_01M5NCV0H8F1897K2VGSWM7BVX","modified_at":"2026-10-23T18:02:56.116818148Z","published_at":"2018-06-05T13:29:00.203Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-1000180","https://security-tracker.debian.org/tracker/CVE-2018-1000180"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-1000180#Debian:14/bouncycastle","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-1000180"}],"summary":"Bouncy Castle BC 1.54 - 1.59, BC-FJA 1.0.0, BC-FJA 1.0.1 and earlier have a flaw in the Low-level interface to RSA key pair generator, specifically RSA Key Pairs generated in low-level API with added"}