{"action":"Upgrade ruby-zip to 1.2.2-1 or later.","affected":[{"fixed":"1.2.2-1","introduced":"0"}],"component":"ruby-zip","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.2.2-1"],"id":"tcs_01M5NCV5VBJFBSZQ9JBPZVRHEC","modified_at":"2026-10-23T18:00:12.566643381Z","published_at":"2018-06-26T16:29:02.353Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-1000544","https://security-tracker.debian.org/tracker/CVE-2018-1000544"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-1000544","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-1000544"}],"summary":"rubyzip gem rubyzip version 1.2.1 and earlier contains a Directory Traversal vulnerability in Zip::File component that can result in write arbitrary files to the filesystem. This attack appear to be e"}