{"action":"Upgrade flask to 1.0.2-1 or later.","affected":[{"fixed":"1.0.2-1","introduced":"0"}],"component":"flask","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.0.2-1"],"id":"tcs_01M5NCV9V2TJTKTNM3CDNR2ZPC","modified_at":"2026-10-23T18:03:53.487778170Z","published_at":"2018-08-20T19:31:45.340Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-1000656","https://security-tracker.debian.org/tracker/CVE-2018-1000656"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-1000656","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-1000656"}],"summary":"The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of servic"}